• last updated 10 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Added checkbox and radio button gifs for use by the new formbuilder enhancements

    • binary
    /openacs-4/packages/acs-subsite/www/shared/checkboxchecked.gif
    • binary
    /openacs-4/packages/acs-subsite/www/shared/radiochecked.gif
APM enhancement: If a package you want to install requires another package that isn't installed nor selected, it simply adds the required package to the list of packages to install. That way you don't have to go back and forth between the two package installation screens when you want to install a package, the APM does it for you.

    • -45
    • +118
    /openacs-4/packages/acs-tcl/tcl/apm-install-procs.tcl
Implemented some enhancements to the form builder:

- support a -mode switch on forms, which can be either 'display' or 'edit'. If 'display', all fields are grayed out, and the pretty value is displayed instead of the internal value (e.g. the label of the element of a list).

- support multiple buttons on the form. Used for the 'Edit' button, but can be used for other buttons as well.

- Fixed all the standard templates to include the new buttons and to use the <label> tag.

- Added an example to the documentation showing how this new display/edit mode looks.

Fixed bug #121: Entry-edit bombs if you use back button

- Missing comma in apm_package_instantiate_and_mount

- Fixed display to work for daily and weekly scheduled procedures

Added bugfix from 4.6

change to allow comments on form and validate sections of ad_form

added a comment at the top saying what this file is for

minor html fix to avoid unclosed <ul> when there are no subscribers

fixed duplicated code

more conlict markers cleaned up, sorry

fixing copy checked in with conflicts

Added parameter and check to condition scanning of Qmail queue for replies,

since not everybody will have qmail installed and setup for that. Bumped

package version to allow upgrading.

making apm_load_catalog_files simply return in case acs-lang hasn't been installed yet

default apm_higher_version_installed_p to 0 since if no version is installed at all it follows that no higher version is installed

Removed extraneous declaration of acs_attribute__create_attribute.

Patches to make OpenACS PG 7.3 compatible.

  1. … 40 more files in changeset.
Replaced ns_schedule_daily with ad_schedule_proc.

Granted Tilmann Singer full commit rights to openacs4

The link to the RSS file must be a fully qualified URL, including http://hostname.

Added some documentation to the user-extension-procs library.

Fixed problem discussed in this thread: http://openacs.org/forums/message-view?message_id=51478 about how site nodes get their context_id set. I took Barry's suggestion and use the parent site node object id by default, and then, if there's no object mounted here, fall back on the old package_id of the subsite through which you're currently mounting the new package.

Flush paginator cache when a message is posted or deleted. Added context bar to moderate/message-delete page

Allow deletion of messages.

Added an --install new package-- option when you create a new application. This just bounces you off to the /acs-admin/apm/packages-install page.

- Regenerated HTML docs

- changed SDM urls to point to Bug-Tracker

- Updated release docs

- Updated some AOLserver URLs

making the check-catalog.sh script verify that package version in catalog files is same as in info files, made script accept multiple package keys

    • -31
    • +51
    /openacs-4/packages/acs-lang/bin/check-catalog.sh
the check-catalog.sh script spotted that I had mistakenly committed bogus package versions for the catalog files