• last updated 5 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
creation

    • -0
    • +50
    ./oracle/forums-reading-info-create.sql
    • -0
    • +18
    ./oracle/forums-reading-info-drop.sql
Insert forums-reading-info-drop to drop

store and display reading info

    • -0
    • +225
    ./postgresql/forums-reading-info-create.sql
    • -0
    • +1
    ./postgresql/upgrade/upgrade-1.3d5-1.3d6.sql
  1. … 17 more files in changeset.
Merged changes to HEAD ...

    • -0
    • +96
    ./oracle/upgrade/upgrade-1.3d3-1.3d4.sql
  1. … 1555 more files in changeset.
Forgot the function that needed upgrades as well. Good to have sites that acutally upgraded from 4.6 around :-). ORACLE: NOT TESTED. NOT SURE IF IT IS THE PROPER THING. PLEASE TEST.

    • -1
    • +95
    ./oracle/upgrade/upgrade-1.3d3-1.3d4.sql
Made sure that old forum instances have the package_id set correctly. For newer ones acs_object__new should take care of it.

    • -0
    • +2
    ./oracle/upgrade/upgrade-1.3d3-1.3d4.sql
  1. … 1 more file in changeset.
file upgrade-1.3d3-1.3d4.sql was initially added on branch oacs-5-3.

    • -0
    • +0
    ./oracle/upgrade/upgrade-1.3d3-1.3d4.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-1.3d3-1.3d4.sql
First shot at merging oacs-5-2 apps used in .LRN to HEAD.

    • -22
    • +14
    ./oracle/forums-forums-create.sql
    • -8
    • +20
    ./oracle/forums-messages-package-create.sql
    • -0
    • +90
    ./oracle/upgrade/upgrade-1.0.6-1.0.7d.sql
    • -3
    • +27
    ./oracle/upgrade/upgrade-1.1.1-1.1.2d1.sql
    • -0
    • +11
    ./oracle/upgrade/upgrade-1.2.0d4-1.3d1.sql
    • -34
    • +28
    ./oracle/upgrade/upgrade-1.2d1-1.2d2.sql
    • -22
    • +18
    ./postgresql/forums-forums-create.sql
    • -14
    • +8
    ./postgresql/forums-forums-drop.sql
    • -1
    • +1
    ./postgresql/forums-messages-package-drop.sql
  1. … 2464 more files in changeset.
Initial import of forums version 1.2.0d4

    • -5
    • +114
    ./oracle/forums-notifications-sanitize.sql
    • -34
    • +46
    ./oracle/forums-search-create.sql
    • -0
    • +0
    ./oracle/upgrade/upgrade-0.1d-0.2d.sql
    • -0
    • +0
    ./oracle/upgrade/upgrade-0.2d-0.3d.sql
    • -0
    • +0
    ./oracle/upgrade/upgrade-0.3d-0.4d.sql
    • -0
    • +402
    ./oracle/upgrade/upgrade-1.0.6-1.0.7d.sql
    • -0
    • +0
    ./oracle/upgrade/upgrade-1.0d2-1.0d3.sql
    • -0
    • +0
    ./oracle/upgrade/upgrade-1.0d3-1.0d4.sql
    • -0
    • +285
    ./oracle/upgrade/upgrade-1.0d4-1.0.1d2.sql
    • -0
    • +11
    ./oracle/upgrade/upgrade-1.1.1-1.1.2d1.sql
    • -0
    • +1
    ./oracle/upgrade/upgrade-1.1d1-1.1d2.sql
  1. … 256 more files in changeset.
Initial import of forums version 1.2.0d4

    • -61
    • +68
    ./oracle/forums-forums-create.sql
    • -69
    • +77
    ./oracle/forums-forums-package-create.sql
    • -59
    • +72
    ./oracle/forums-messages-create.sql
    • -178
    • +342
    ./oracle/forums-messages-package-create.sql
    • -0
    • +61
    ./oracle/forums-notifications-init.sql
  1. … 35 more files in changeset.
Update package_id for projects

    • -0
    • +11
    ./oracle/upgrade/upgrade-1.2.0d4-1.3d1.sql
file upgrade-1.2.0d4-1.3d1.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-1.2.0d4-1.3d1.sql
file upgrade-1.2.0d4-1.3d1.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-1.2.0d4-1.3d1.sql
Added base_url and page_size to thread chunck. Made sure the package_id for forums is set in acs-objects

  1. … 2 more files in changeset.
increase forums_forums.charter to 4000 chars, add length checking in the forums form, bump version info

    • -0
    • +22
    ./postgresql/upgrade/upgrade-1.2.0d3-1.2.0d4.sql
  1. … 3 more files in changeset.
file upgrade-1.2.0d3-1.2.0d4.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./oracle/upgrade/upgrade-1.2.0d3-1.2.0d4.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-1.2.0d3-1.2.0d4.sql
Last poster was updated with the user_id value of the root message instead of with the user_id received by forums_message.new

    • -2
    • +2
    ./oracle/forums-messages-package-create.sql
    • -2
    • +2
    ./oracle/upgrade/upgrade-1.2d1-1.2d2.sql
Fix oracle syntax and query for updating forums_messages.last_poster

    • -26
    • +8
    ./oracle/upgrade/upgrade-1.2d1-1.2d2.sql
fix upgrade script on 5.1

Applied patch to fix bug #2761.

    • -6
    • +18
    ./oracle/forums-messages-package-create.sql
    • -6
    • +18
    ./oracle/upgrade/upgrade-1.2d1-1.2d2.sql
file upgrade-1.2d2-1.2d3.sql was initially added on branch oacs-5-2.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-1.2d2-1.2d3.sql
perfomance improvements

  1. … 1 more file in changeset.
Fix permissions change so it works if explciti read, write, or create exist on

forums objects.

    • -3
    • +27
    ./oracle/upgrade/upgrade-1.1.1-1.1.2d1.sql
Fixed drop script for the empty-package case at least.

    • -1
    • +1
    ./postgresql/forums-messages-package-drop.sql
commit to OACS-5-2 merge of changes on OACS-5-1

(using tag vg-merge-dotlrn-2-1-20050922) for packages under dotlrn-all

    • -21
    • +13
    ./oracle/forums-forums-create.sql
    • -21
    • +12
    ./postgresql/forums-forums-create.sql
    • -14
    • +7
    ./postgresql/forums-forums-drop.sql
    • -0
    • +52
    ./postgresql/upgrade/upgrade-1.1.2d4-1.1.2d5.sql
  1. … 86 more files in changeset.
file upgrade-1.1.2d4-1.1.2d5.sql was added on branch oacs-5-2 on 2005-09-26 09:03:13 +0000

file upgrade-1.1.2d4-1.1.2d5.sql was added on branch oacs-5-2 on 2005-09-26 09:03:14 +0000

Resolving outstanding permissions bugs in forums. Please let me know if you have any trouble with it.

    • -21
    • +13
    ./oracle/forums-forums-create.sql
    • -21
    • +12
    ./postgresql/forums-forums-create.sql
    • -14
    • +7
    ./postgresql/forums-forums-drop.sql
    • -0
    • +52
    ./postgresql/upgrade/upgrade-1.1.2d4-1.1.2d5.sql
  1. … 3 more files in changeset.
file upgrade-1.1.2d4-1.1.2d5.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./oracle/upgrade/upgrade-1.1.2d4-1.1.2d5.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-1.1.2d4-1.1.2d5.sql
The forums_forum package must be rebuilt as well.

    • -0
    • +90
    ./oracle/upgrade/upgrade-1.0.6-1.0.7d.sql