• last updated 1 hour ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
- update postgres function to modern style plpgsql definitions using dollar quoting

    • -90
    • +116
    ./postgresql/rss-generation-create.sql
    • -5
    • +10
    ./postgresql/rss-generation-drop.sql
    • -25
    • +29
    ./postgresql/upgrade/upgrade-0.3d2-0.3d3.sql
    • -15
    • +34
    ./postgresql/upgrade/upgrade-0.3d4-0.3d5.sql
  1. … 38 more files in changeset.
Simple package drop now works for PG and probably Oracle, too. The drop

scripts had never been tested - they misspelled two service contract

operations (quite bad seeing as there are *only* two sc operations)

    • -5
    • +4
    ./postgresql/rss-generation-sc-drop.sql
Merged oacs-5-5 branch of .LRN packages to HEAD.

    • -1
    • +0
    ./postgresql/upgrade/upgrade-0.3-0.4.sql
  1. … 86 more files in changeset.
Removed broken upgrade script

    • -1
    • +0
    ./postgresql/upgrade/upgrade-0.3-0.4.sql
Replacing this with a much simpler, smarter ALTER TABLE.

Fixed bone-headed mistake

Added an upgrade file for the type change of a foreign key that should be

an integer rather than varchar. This should work even if someone's made

the change manually in their local install.

  1. … 1 more file in changeset.
file upgrade-0.4d1-0.4d2.sql was initially added on branch oacs-5-5.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.4d1-0.4d2.sql
PG 8.3 catches a boneheaded foreign key reference of type varchar(100) to

object_id (integer).

    • -1
    • +1
    ./postgresql/rss-generation-create.sql
    • -0
    • +1
    ./postgresql/upgrade/upgrade-0.3-0.4.sql
First shot at merging oacs-5-2 apps used in .LRN to HEAD.

    • -0
    • +29
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
  1. … 2478 more files in changeset.
Added package definition to ensure propagation of the ora9i compatibility changes. Not relevant for PG.

    • -0
    • +29
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
Added package definition to ensure propagation of the ora9i compatibility changes. Not relevant for PG.

    • -0
    • +29
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
commit to HEAD of merge of changes on oacs-5-1 branch between tags jcd-merge-5-1-20050111 and jcd-merge-5-1-20050224

    • -2
    • +12
    ./postgresql/rss-generation-create.sql
  1. … 318 more files in changeset.
Fix define function args to match oracle parameter names

    • -1
    • +1
    ./postgresql/rss-generation-create.sql
file upgrade-0.3d5-0.3d6.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.3d5-0.3d6.sql
Add define_function_args for rss_gen_subscr__new

Add rss_gen_subscr__del function and define function args.

Add tcl procedure to del rss feed subscription.

    • -2
    • +12
    ./postgresql/rss-generation-create.sql
  1. … 3 more files in changeset.
file upgrade-0.3d4-0.3d5.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.3d4-0.3d5.sql
fix the name_method name for oracle

commit to HEAD of merge of changes on oacs-5-1 branch between tags jcd-merge-5-1-20040724 and jcd-merge-5-1-20050111

    • -0
    • +70
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
    • -1
    • +8
    ./postgresql/rss-generation-create.sql
  1. … 2272 more files in changeset.
file upgrade-0.3d2-0.3d3.sql was initially added on branch oacs-5-1.

    • -0
    • +0
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
    • -0
    • +0
    ./postgresql/upgrade/upgrade-0.3d2-0.3d3.sql
Added RSS enclosure support and modified the plsql api to allow a null summary_context_id. Null summary_context_id will automatically be set to the newly created subscr_id.

    • -0
    • +70
    ./oracle/upgrade/upgrade-0.3d2-0.3d3.sql
    • -1
    • +8
    ./postgresql/rss-generation-create.sql
  1. … 2 more files in changeset.
Oracle9i porting changes

- Changed procedure names from delete to del

- Changed view declaration to use actual column names

- Changed "rel_constraints_violated_one" and "rel_constraints_violated_two"

(http://openacs.org/forums/message-view?message_id=81045)

  1. … 273 more files in changeset.
merge of 4.6.3b1 to HEAD

    • -0
    • +32
    ./oracle/upgrade/upgrade-0.2d1-0.2d2.sql
    • -3
    • +3
    ./postgresql/rss-generation-create.sql
  1. … 13 more files in changeset.
file upgrade-0.2d1-0.2d2.sql was initially added on branch oacs-4-6.

    • -0
    • +0
    ./oracle/upgrade/upgrade-0.2d1-0.2d2.sql
Upgraded rss-support to work with Oracle

    • -0
    • +32
    ./oracle/upgrade/upgrade-0.2d1-0.2d2.sql
  1. … 28 more files in changeset.
Merged over changes from HEAD

    • -2
    • +12
    ./postgresql/rss-generation-create.sql
  1. … 37 more files in changeset.
I've changed "timestamp" to "timestamptz" and have begun fixing some

code that used to be legal but as of PG 7.3 is not. You can no longer

subtract an integer from a timestamp but must cast to date, "timestamp"

disappeared (must use "interval" now), "datetime" disappeared ("timestamptz"),

and suchwhat.

Not done but closer than it was before ...

    • -2
    • +2
    ./postgresql/rss-generation-create.sql
  1. … 38 more files in changeset.
Formatted the rss_generation__new proc header.

    • -2
    • +12
    ./postgresql/rss-generation-create.sql
merge bartt PG 7.3 fixes from HEAD

    • -1
    • +1
    ./postgresql/rss-generation-create.sql
  1. … 54 more files in changeset.